I suggest you ...

Idea 2017.1.1 - Cannot load project: com.intellij.ide.plugins.PluginManager$StartupAbortedException: Fatal error initializing plugin QAPlug

Upgraded to Idea 2017.1.1 and now get the following error message when I try to launch the application:
Cannot load project: com.intellij.ide.plugins.PluginManager$StartupAbortedException: Fatal error initializing plugin QAPlug

Running IntelliJ IDEA version 2017.1.1
QAPlug version 1.3.12
QAPlug - PMD version 1.3.8

Once I disable the QAPlug Plugins IntelliJ starts correctly.

82 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Ben Shapiro shared this idea  ·   ·  Admin →

    5 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Jürgen Stadler commented  · 

        @René: This workaround doesn't work for me with 2017.1.2. :-(

      • Dave Jenkins commented  · 

        Installing "PMDPlugin" (enabled or disabled) did not make "QAPlug" work for me.

      • René commented  · 

        A workaround for this issue:

        1) install the plugin "PMDPlugin" from vendor "bodhi"
        2) disable that newly installed "PMDPlugin"

        Now QAPlug with PMD works again!
        (Apparently this way your receive some missing dependencies of QAPlug and it will work)

      • René commented  · 

        A work around to get QAplugin to work again:
        1) install the plugin "PMDPlugin" of vendor "bodhi".
        2) Disable the PMDPlugin

        Now QAplug works! (apparently this other plugin adds some required dependencies)

      Feedback and Knowledge Base